HELP! Stuck on "Fetching Your Addresses" (Ledger Nano X - Brave Browser)


It has been quite some time since I have logged into my NIMIQ account using my Ledger Nano X hardware wallet on the Brave browser.

Now, upon trying to check up on my funds, it can’t seem to complete the log in process. It just stays stuck in the “Fetching Your Addresses” phase (see screenshot below) for the longest time. I have also disabled the Brave browser “Shields” to no avail.

Have I missed a few “upgrade” steps that needed to be done on my side in order to allow use of my Ledger Nano X with the new NIMIQ Wallet 2.0? Please advise.

Note that I am due for a Firmware update on my Ledger Nano X. Will updating the firmware solve this issue? I was not keen on updating the firmware as I have lost my 24 word seed. I plan to first transfer my NIM to another ledger wallet in order “reset” my current one.

Please help!
I’m hoping to be able to access my funds again and not loose them.

Hope to hear from you soon.


Nimiq 2 isn’t out yet. I can’t really help you with this but make sure your system clock is correct.

Hey thanks.

By “system clock” you mean the time zone settings on my computer? Because I have recently relocated from a different country. Can the time zone really affect the communication between my Ledger device and the NIMIQ wallet?


@MA_NIM Each computer has a clock that should be the same no matter which time zone you are in, and a time zone setting that offsets the time. Changing the clock will prevent connecting to the Nimiq network because it relies on time.

Maybe, when switching countries, you accidentally switched the system clock to match clocks in the country instead of switching the time zone?

@code3z, thanks you so much for the advice. Yes, this could be the most probable cause as to why I can’t connect to my wallet. Now, I am worried because I am not quite sure on how I changed the “system clock”, and whether I am able to revert the system clock back to its previous default “system clock” settings on Windows 10. I bought my laptop from Auckland, NZ, where I have originally set up my NIMIQ wallet, and earlier this year we relocated to Dubai, UAE.

Below are some screenshots of my attempt to change my laptop’s settings to revert back to when I was in Auckland, NZ.

I tried to change the “Country/Region” settings back to New Zealand, and language back to English - New Zealand (Previously English US). Also, I do remember changing the “First Day of Week” from Monday to Sunday (which is the 1st days of the week here in Dubai, UAE), I changed it back to Monday. After which, I set to “automatically” set time and time zone. I then clicked on “Sync now”, but time synchronisation failed for some reason.

Do you have any advice on how to properly revert my “system clock” on Windows 10? Or, is there any other work around to this that might work? Maybe using another PC/Laptop to access my NIMIQ Wallet? Is it possible to use a different PC/Laptop to attempt to access my NIMIQ Wallet, maybe using a friend’s PC?

Once again, thank you @code3z for taking the time to clearly explain my situation.
Hope to hear from you soon.

Kind Regards.

@MA_NIM If the time zone and clock are accurate, then this is probably not the issue. Might want to try on a different computer if possible. You can also ask in the discord.

I have the same issue here with a ledger nano S with firefox and linux debian 11

System clock is fine
ledger is working on the same system with metamask…

Anyone can help ?

@MA_NIM Have you tried a different browser?
Firefox is recommended.

Unfortunately, none has worked so far.

I have updated my Ledger to the latest Firmware and reinstalled the Nimiq App. Then I tried to access my Nimiq account again from two different laptops (Windows, and MacOS).

I also tried accessing my account from Firefox and Google Chrome. I tried Safari on MacOS but the browser seems to not be supported.

People in the same boat as I need help and/or advice from the Nimiq technical team, as all our funds can not be accessed at this point (stuck at “fetching your addresses”).

Hope someone can help.


I have just tried to reproduce the issue and succeeded:

LogNative.js:46 [W 12:08:45] BaseConsensus: Failed to retrieve transaction receipts for ************** from wss://…: Timeout
msg	@	web.js:1
msg	@	web.js:1
w	@	web.js:1
_requestTransactionReceiptsByAddress	@	web.js:1
await in _requestTransactionReceiptsByAddress (async)		
getTransactionReceiptsByAddress	@	web.js:1
getTransactionReceiptsByAddress	@	web.js:1
await in getTransactionReceiptsByAddress (async)		
requestTransactionReceipts	@	network.46ebef27.js:921
await in requestTransactionReceipts (async)		
(anonymous)	@	network.46ebef27.js:1284
_receive	@	network.46ebef27.js:415
postMessage (async)		
(anonymous)	@	chunk-vendors.2d412cb5.js:17
_call	@	chunk-vendors.2d412cb5.js:17
call	@	chunk-vendors.2d412cb5.js:17
call	@	chunk-vendors.2d412cb5.js:17
requestTransactionReceipts	@	chunk-vendors.2d412cb5.js:17
(anonymous)	@	chunk-common.17fd6781.js:1
await in (anonymous) (async)		
_collectLedgerOrBip39WalletInfo	@	chunk-common.17fd6781.js:1

If this timeout occurs on all nodes it will be stuck on the loading screen.
It seems ( I have not validated this ) that the timeout only occurs on nodes hosted by the team. You just need to try this a few times until your browser connects to at least one of the community nodes and it should work fine. So when you are stuck just hit F5 and try again .

1 Like