Nimiq Safe UI feedback

#1

Feedback, screenshots and reports of new UI of the Nimiq Safe

1 Like
#2

#3

As soon as you add an actual number that is not a zero, it will jump back to 5 decimals.

That is a browser <input type="number"> limitation.

#4

I stand corrected. When you add enough zeros in front of the first number, it allows it.

Thanks, I’ll look into it!

#5

Using an iPhone and Safari, if I click on GetNim or Apps in the new version of the Safe, I am directed to the new website ‘teaser’ instead of the GetNim or Apps pages that were there before.

#6

Okay it seems to have resolved, and now I am directed to the correct pages.

#7

new account, password gggggggg works or 11111111. I would change.

1 Like
#8

Very clean overall, for some bug swatting a few users (including myself) have run into an error where the Safe won’t allow you to click on the “send” button when making a transaction sometimes. Trying to replicate it myself.

#9

I showed the new safe to a few people and they were all really positive. intuitive design really!

one problem they encountered is when typing in your password. you see the dots fill up, but as soon as the bar is filled, you don’t get any feedback whether a new char was typed or not. so if you fatfinger on your keyboard and especially on mobile, you have no way to know how many chars you typed in. maybe add some sort of visual feedback whenever the whole row shifts to the left?

#10

there is also confusion when using one account on multiple machines. when you are logged in on both machines and create a new address on one, it doesn’t update on the other machine.
maybe add an “update” button for addresses (I know you need the private key for that). but it would be a bit more convenient then logging out and back in.

maybe we can also have an faq directly in the safe so people can check on those things directly?

2 Likes
#11

another issue: if you click on a transaction request link and get redirected to the safe, you have no way of knowing when consensus is established. example is using paynimbot on telegram. you have to wait and ocasionally click the “send” button which is not ideal

#12

Good point! We’ll look into that!

#13

more things: is it intentional that the whole red box is the trigger for the address creation? it is at least for me. firefox windows 10, everything else works fine.

#14

That’s a side effect of how the button is built currently. It’s changing with the next small update in the next days.

#15

can we get the option to edit the address name in the address overview? I know (now) that it’s also possible in the account rename tab, but the first place to look for it would be here, in the address overview. going to the account tab seems like a detour, especially if you want to rename your addresses in regard to balance and don’t really know their identicon…