DevNet Staking Wallet Feedback

Early Access to DevNet staking in the Nimiq Wallet

With Nimiq’s evolution to Proof-of-Stake now in the DevNet phase, we’ve begun to integrate staking into the Nimiq Wallet. While many features are still yet to be implemented, we thought it would be nice to share early access with our community to let you get an idea of how Nimiq’s next upgrade will look and feel.

Read all the details in the dedicated blog post.

The Wallet is running on the real deal, and your feedback is invaluable

The Nimiq Wallet is actually connected to a running network of Proof-of-Stake DevNet nodes currently managed by the Nimiq team. Nothing you see in the DevNet staking Wallet is a simulation. Sending NIM, staking, un-staking and payouts are real (in devNIM). Currently, our focus lies on running the DevNet under regular conditions. Security hardening will follow later. If you find anything that feels like a bug or have any suggestions for improvements, please post a detailed description of your feedback here (screenshots are appreciated).

1 Like

Awesome! DevNet is sooo fast…
Some feedback - it would be great to stake with multiple validators, to take advantage of highest Trust Score and Highest Reward and payout in wallet or restake - or for any other reason. A super large whale might want to distribute more evenly to spread out risk and help support the decentralization of the network.

4 Likes

I think it too, it will be mind blow to select two validators, one for restake and another for wallet. I think that also small wallets funds with that option would be safer for same market changes.

First of all, congratulations on your milestone !!! After this news, I immediately started testing the DevNet. Now I have found some bugs that I wanted to communicate here.

The equipment I used:
Desktop type: HP, Intel(R) Core™ i7-9750H CPU @ 2.60GHz 2.59 GHz 8GB
Tablet type: Samsung S7
Mobile type: Samsung S22

Browser I used:
Chrome
Internet explore (not yet)
Firefox (not yet)

BUGS

Below you can see the bugs I found:
Desktop: No particulars yet.
Tablet: No particulars yet.

UX Bug 1: Mobile Samsung s22/Chrome:
In the video I made you can see I’m not been able to stake. It won’t let me send some Test Nimiq to the validator address/pool.
animation

UI Bug 1: Mobile Samsung s22/Chrome:

Won’t be able to see the whole stakingbar at once

UI Bug 2: Mobile Samsung s22/Chrome:
The text is jumbled

UI Bug 3: Mobile Samsung s22/Chrome:
The text is not in a line and runs into each other.

UI Bug 4: Mobile Samsung s22/Chrome:
The text is not readable perhaps the green strike area should be slightly larger. And for the rest I see some Dutch and English texts mixed up. But I am sure you were already aware of this :slight_smile:

1 Like

Great stuff team!
I had a look on my iPhone. Staking the 1st account was straightforward.
I then added a 2nd account and it took a little while to find out how to stake this account as the ‘Stake Now’ button on the main page is gone once you’ve staked the 1st account.
Suggestion: maybe have the stake option a visible button when you click into each account, rather than hidden in the account menu
Also, on the main page where you click ‘Stake Now’ it seems to only let you stake the 1st account. Would it be possible (if you have multiple accounts) to have this button visible unless you’ve staked all accounts, and then ask which one you’d like to stake?
Keep up the great work!

3 Likes

I’ve tried it for a few minutes and I am really, really impressed. I have been following this project since you first announced Albatross so it is really exciting to see your vision become a reality. Transactions are so fast I honestly don’t believe that there is a blockchain running and that the numbers are simply changing on my webpage lol

I am using Opera on desktop. This browser doesn’t work for mainnet so I thought it might provide a challenge. So far, everything seems in order. The only bug that I came across occurred when I staked some devnim; the transaction appeared in the history (a deduction to my balance) but there was no sign of it anywhere else; it was like it had been sent in a normal transaction:


I thought this could be due to the epoch system but no amount of waiting resolved the issue. I was confused despite my know-how. However, if I refreshed the page everything appeared as normal, with staking amounts clearly displayed.

I know this is a bit of a nitpick, but I want this release to be absolutely perfect. The amount of effort and love your team has poured into this project means that anything but the very best would be a disservice! Good luck.

3 Likes





So far the devwallet is a great progress. I understand that the devnet might be down here and there but I noticed the history of transaction for more than 24hrs shows as invalid with a x mark and a red line on the amount of Devnim transacted. The other thing i noticed when I changed validator the wallet froze so i just closed the Devwallet app and reopened it. I LOVE HOW FAST THE TRANSACTIONS COME THROUGH. I first tried the staking pool that gives the rewards in the wallet and saw a live rewards payout which i found amazing. I am currently trying the restake pool and will see how that works out. Awesome Job team :clap:

1 Like

To me seeing -0 as value when switching validator feels weird.

1 Like

I have the same issue. I switch Validator from Cool Pool to Pooly McPoolface and I’m not seeing any rewards being shown.

1 Like

Specs during test:
Intel(R) Core™ i7-7700HQ CPU @ 2.80GHz 2.80 GHz 32.0 GB
Windows 10 Home 21H2 19044.1826
Brave Browser Version 1.41.96 Chromium: 103.0.5060.114 (Official Build) (64-bit)

Feedback:

The previously successful transactions yesterday are now considered failed transactions. I thought it was because of delegating my stake to validator with low trust score but DevNet Faucet transaction was shown as failed as well. Recent successful transaction after rows of failed tx’s happened at 7:13am July 16 (4 hours before this post)

I also had instances of browsing freeze. When I interact too fast, it freezes for seconds, sometimes the tab crashes.

overall good job

2 Likes

love the overall user experience. I will second the suggestion for allowing staking for multiple validators.

One suggestion for UI, when choosing your staking amount, the % indicator could be lowered. Currently, when viewing on desktop it overlaps with the vertical dashes.

Great work team!

2 Likes
  • After unstaking, the staking details popup remains open. You must manually close the popup and then refresh to see the option to stake again. Maybe include an unstake success message and/or refresh the popup details to show 0 staked?

Upon staking again, the popup details did not auto-populate the newly staked amount (showed 0.00 NIM staked). After closing the popup and reopening, the newly staked amount shows.

  • Has there been any discussion of a manual claim? Perhaps every 24hrs you are eligible to claim rewards (or just continue to let it grow before claiming). Currently (while it may be fast due to devnet) my wallet is flooded with staking reward hundreds of transactions.

This could be beneficial for keeping the wallet less flooded with transactions and also a tax standpoint for when you take ownership of the crypto rewards.


2 Likes

this is also showing in mine. i am unsure if this occurred before or after I unstaked and switched delegators.

After a day or so wallets with addresses that have NIM staked in “Cool Pool” or “Monopooly” and receive in-wallet rewards become mostly unresponsive - on mobile smartphone or on desktop.

I’ve tried reloading, closing and opening a new tab to refresh, but soon enough the wallets become frozen.

Ctrl-Shift-R (in Chrome browser) is usually needed to refresh the wallets.

With wallets that have multiple addresses, as some suggested, in order to stake with multiple validators the wallets are even worse off. Switching between the staked wallets goes into fetching mode and wallets freeze. Also, if a wallet is fetching and eventually up to date, after switching tabs for a few minutes will make the wallet frozen again when switching back to the wallet tab.

2 Likes

I’ve noticed that after having the Wallet for a while it suddenly becomes frozen. Can’t even open Chrome Console and eventually a pop appears that the tab got stuck.

There’s a blue screen of nothing that shows up when trying to select a new account avatar and missing the button when trying to click it.

Wallet Blue Screen of whaaa

1 Like

I have noticed that in normal chrome it locks the wallet, but in chrome incognito tab it works fine

the same happens in the edge browser

Cool Pool disappeared?
Monopooly is not paying out staking rewards, it seams.

It’s not clear what rewards are being paid by the pools. Some addresses show a growing balance with Monopooly some have an unchanged balance. When changing a validator, somehow a few NIM are added to the account.


At the albatross.nimiq.tools explorer Staking account “NQ38 STAK 1NG0 0000 0000 C0NT RACT 0000 0000” is not found